pod crypto
Cryptography API
Mixins
| AsymKey | A key in an asymmetric key pair |
| Cert | Cert defines the api for an identity certificate. |
| CertSigner | The CertSigner allows you to configure various options for signing a certificate from a CSR to generate a signed certifcate. |
| Crypto | Crypto defines a pluggable mixin for cryptography capabilities in Fantom. |
| Csr | A Certificate Signing Request (CSR) |
| Digest | A message digest algorithm |
| Jwk | Models a JSON Web Key (JWK) as specified by RFC7517 |
| Key | Key defines the api for a cryptographic key. |
| KeyPair | A KeyPair contains a private key and its corresponding public key in an asymmetric key pair. |
| KeyStore | KeyStore stores |
| KeyStoreEntry | Marker mixin for an entry in a keystore |
| PrivKey | A private key in an asymmetric key pair. |
| PrivKeyEntry | A PrivKeyEntry stores a private key and the certificate chain for the corresponding public key. |
| PubKey | A public key in an asymmetric key pair. |
| SymKey | A symmetric key |
| TrustEntry | Keystore entry for a trusted certificate. |
Classes
| Jwt | Models a JSON Web Token (JWT) as specified by RFC7519 |
| San | San defines the api for a Subject Alternative Name based on RFC 5280. |
Enums
| SanType | SanType |